Chrome or Firefox is required. The Android versions of these browsers should work as well, but they're a bit fickle. Some code is thanks to Chris Valleskey.